Tag Archives: Robot Karol

Atari Adventure in Scratch

By | 28.3.2017

Man kann auch mal für Aufgaben erst eine Lösung präsentieren und dann die Schüler und Schülerinnen mal machen lassen und schauen, wie weit sie sich ihr nähern können. Wir hatten eigentlich vorerst schon mit Scratch aufgehört und uns Robot Karol genähert, da erinnerte ich mich an ein Computerspiel meienr Kindheit. Ich kannte dieses Spiel – Atari Adventure – aus der Reklame, hatte es aber selber nie, sondern nur so ähnliche. Und dieses Atari Adventure war berühmt für die reichhaltige Fülle der Welt, in der man sich bewegen konnte, und die ansprechende Grafik. So sah das Spiel aus: Solche Zeiten waren… Read More »

Schleifchenmachen

By | 11.8.2014

In der 7. Klasse lernen die Schüler am bayerischen Gymnasium Algorithmik „mit einem Programmiersystem, mit dem sie die Algorithmen intuitiv umsetzen können und bei dem die Einzelschritte des Ablaufs altersgemäß visualisiert werden“ (Lehrplan). Das heißt in der Regel: Robot Karol, das virtuelle Legomännchen. Es kann Ziegelsteine vor sich ablegen und aufnehmen, kann sich nach links und rechts drehen und einen Schritt nach vorne machen. Aus diesen Anweisungen bastelt man sich ein Programm. Wenn man dabei überlegt vorgeht, schreibt man beispielsweise nicht: schritt() linksdrehen() schritt() linksdrehen() schritt() linksdrehen() sondern: wiederhole 3 mal   schritt()   linksdrehen() *wiederhole weil man erkannt hat, dass da… Read More »

Robot Karola

By | 23.11.2013

Ein vor allem in der Unterstufe häufig verwendetes Informatiksystem ist Robot Karol von Ulli Freiberger: eine kleine Roboterfigur, die man mit einer einfachen Programmiersprache steuert – so richtig mit Schleifen und bedingten Anweisungen. Über eine polnische Version geht das auf eine amerikanische Urfassung und die Turtle-Tradition zurück. In Robot Karol lässt man den Roboter einfache Strukturen, Labyrinthe oder ganze Städte bauen oder sortiert Kistenstapel nach dem Bubblesort-Verfahren. Karol kann sich bewegen und rote Ziegel vor sich stapeln und wieder aufheben. Standardmäßig sieht Karol so aus: Man kann diese vier Grafiken aber auch durch andere Bilder im gleichen Format ersetzen, selbstgemachte… Read More »

Neues von Robot Karol

By | 6.5.2007

Also, nicht wirklich Neues, aber Nettes: Ein Schüler hat zu Hause eine Sammlung von Anweisungen geschrieben, mit denen man Texte schreiben kann. Für jeden Buchstaben eine Anweisung. Und davor gibt es sogar eine Art try/except, eine Abfrage am Anfang, ob die Welt auch lang genug ist für einen Buchstaben: Anweisung StartPosition   Schnell   wiederhole 6 mal    wenn NichtIstWand dann     Schritt     sonst     Beenden    *wenn   *wiederhole   LinksDrehen *Anweisung (Wie man mit Robot Karol eigene Bedingungen außer NichtIstwand und so weiter definiert, haben wir noch nicht besprochen. Letztlich geht das so ähnlich, wie der… Read More »

Computerspiele objektorientiert

By | 26.1.2007

In der 6. Klasse lernen Schüler anhand von Vektorgraphik-Programmen, was Klassen und Objekte sind. Das ist noch anschaulich. Später und in der 7. Klasse sollen die Schüler dann auch bei der Textverarbeitung und im Internet objektorientiert arbeiten und Zeichen, Absätze, Textfelder, E-Mails und Hyperlinks als Objekte begreifen. Das halte ich für nicht mehr so anschaulich. Wieviel bringt es, die Klasse Hyperlink mit den Attributen „Verweisziel“ und „Verweistext“ zu verdeutlichen? Die Punktschreibweise zu üben mit MeineMail.Empfänger=bla@blubb.de und MeineMail.Absenden(Empfänger)? Ich glaube nicht, dass die Schüler diese abstrakteren Objekte wirklich als Objekt verstehen. Allerdings soll man natürlich den Umgang mit Internet und E-Mails… Read More »

Geheimnisvolle Ruinenstadt mit Robot Karol

By | 6.5.2006

Robot Karol ist ein weit verbreitetes Programm für den Anfangsunterricht Informatik. (Herunterladen und Informationen.) Man bewegt darin einen Roboter, der nur die Anweisungen Linksdrehen, Rechtsdrehen, Vorwärtsschritt, Hinlegen und Aufheben (jeweils eines Steines bzw. einer Marke) versteht. Man kann kann aus diesen elementaren Anweisungen aber neue Anweisungen zusammenstellen und diesen Namen geben: zum Beispiel Umdrehen (=zweimal Linksdrehen), Sidestep (=Linksdrehen, Schritt, Rechtsdrehen), Zurück (=Umdrehen, Schritt, Umdrehen). Steuern kann man den Roboter durch Wiederholungsschleifen mit fester Anzahl oder Abbruchbbedingung und Wenn-dann-sonst-Bedingungen. Es gibt keine Variablen (aus didaktischen Gründen) und damit auch keine For-Next-Schleife, obwohl die die Schüler schon vermisst haben. Rekursion ist möglich.… Read More »