Neues von Robot Karol

Also, nicht wirklich Neues, aber Nettes:

Ein Schüler hat zu Hause eine Sammlung von Anweisungen geschrieben, mit denen man Texte schreiben kann. Für jeden Buchstaben eine Anweisung. Und davor gibt es sogar eine Art try/except, eine Abfrage am Anfang, ob die Welt auch lang genug ist für einen Buchstaben:

Anweisung StartPosition
  Schnell
  wiederhole 6 mal
   wenn NichtIstWand dann
    Schritt
    sonst
    Beenden
   *wenn
  *wiederhole
  LinksDrehen
*Anweisung

(Wie man mit Robot Karol eigene Bedingungen außer NichtIstwand und so weiter definiert, haben wir noch nicht besprochen. Letztlich geht das so ähnlich, wie der Schüler hier vorgegangen ist.)

karol_thomasrau.jpg

Das Programm zur Graphik sieht so aus:

Programm
 StartPosition
 t h o m a s r a u
*Programm

11 Antworten auf „Neues von Robot Karol“

  1. hallo herr rau,
    ich habe mal eine große Frage.Ich muss für Informatik eine Hausaufgabe machen,wo ich mit Robot Karol ein Feld mit unbekannter Größe durchlaufen soll,Karol muss aber jedes Feld abgelaufen haben.Ich verzweifel gerade vor meinem PC und muss die HA in 4 Stunden abgeschickt haben.Können sie mir vllt. ein paar Tipps geben?

  2. WIIR HABEN GRAD THEMA ROBOT KAROL IN INFORMATIIKK!! ICH HASSEE ESS. ALLES SOO SCHWER KOMPLIZIERT BLABLABLA.. ICH HASSE ES

  3. Hey leute ich muss eine programm schreiben was für jeden labyrinth was mann auch zusammen stellen kann geht . In den labyrinth soll der roboter eine marke (egal wo ) finden und dann auf der stehen bleieben . Wenn jemand eine lösung hat bitte senden :) Danke

  4. woow bist du lüstig . wenn du dieses pro. net schrieben kannst weil du zu dumm dafür bist dann sei lieber ruhig . Und wenn du schon so schlau bist dann schreib mal diese pro. hier mit ins chat . Ich hab diese pro. schon . mal gucken ob du es schafst und wenn du es schafst dann muss es für jedes laby gehen . Viel Spass noch !!

  5. Na, immerhin war die Frage etwas freundlicher gestellt als diese Reaktion. Vielleicht hätte ich auch etwas geduldiger sagen sollen: diese Aufgabe ist gar nicht so leicht. Musterlösungen genau dafür gibt es anderswo im Internet (selber suchen), aber die macht wenig Sinn. Zumindest einen eigenen Plan muss man haben, sonst bringt das gar nichts.

    (Und bitte nichts hier in den Chat stellen. Digital natives, my foot.)

  6. Hallo,
    ich hoffe diese Seite wird noch genutzt:)
    wir schreiben in zwei wochen eine informatikarbeit über robot karol.
    Eigentlich habe ich alles verstanden und beherrsche es auch, dass einzigste was ich nicht ganz verstehe ist mit karol den ausgang aus einem labyrinth finden. geht jedes labyrinth mit ein und den selben anweisungen oder muss man für jedes eine extra anweisung schreiben?

  7. Genutzt wird sie schon, aber nicht als Forum. Kurzfassung: nein, mit den Anweisungen soll man aus jedem Labyrinth herauskommen, nicht nur aus einem. Sonst wäre das ja langweilig. (Es gibt aber auch Labyrinthe, bei denen man mit der einfachen Anweisung nicht herauskommt. Stattdessen braucht man eine komplizierte. Aber auch da: nur eine für alle.) Frag doch deinen Lehrer, persönlich oder per Mail? Der antwortet gerne, davon bin ich überzeugt.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.